Прочее:Удаление конфигурации master-port

Материал из MikroTik WiKi rus
Перейти к: навигация, поиск

Удаление master-port в MikroTik RouterOS 6.41 и выше

Начиная с RouterOS 6.41 и выше из настроек удалена настройка master-port о чем было предупреждение на официальном сайте:

What's new in 6.41 (2017-Dec-22 11:55):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload). This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" 
option as such. Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions. The rest of RouterOS Switch specific configuration remains untouched in usual menus for now. Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


RouterOS 6.40.5 было:
RouterOS 6.40.5 было

RouterOS 6.41 стало:
RouterOS 6.41 стало

Из скриншотов видно, что в версии 6.41 пропала опция "Master Port:" и информационное поле "Switch". Теперь вся информация, которая передается на 2-м уровне модели OSI будет передаваться через Bridge-интерфейс. Использование swich-чипа (hw-offload) будет автоматически активировано автоматически в случае такой возможности. По умолчанию при добавлении любого интерфейса в Bridge у него будет активирована опция "Hardware Offload", которая будет передавать всю информацию 2-го уровня через switch-чип. Если эту опцию убрать, то обработка будет осуществляться силами операционной системы.

Рассмотрим, что это значит для сетевых администраторов. При переходе на RouterOS 6.41 и выше с RouterOS версий 6.40.5 и ниже все настройки master-port будут автоматически перенесены в Bridge-интерфейс.

Icon-warn.png

Предупреждение: Если произвести downgrade до версии, которая поддерживает master-port, то настройки не будут возвращены на место. Настоятельно рекомендуется сделать резервную копию до обновления.


Было:
/interface ethernet
set [ find default-name=ether1 ] name=ether1-WAN1
set [ find default-name=ether5 ] name=ether5-LAN1-master
set [ find default-name=ether2 ] master-port=ether5-LAN1-master name=ether2-LAN1
set [ find default-name=ether3 ] master-port=ether5-LAN1-master name=ether3-LAN1
set [ find default-name=ether4 ] master-port=ether5-LAN1-master name=ether4-LAN1
/ip address
add address=10.10.10.1/24 interface=ether1-WAN1 network=10.10.10.0
add address=192.168.0.1/24 interface=ether5-LAN1-master network=192.168.0.0
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1-WAN1

Стало:
/interface bridge
add admin-mac=6C:3B:6B:3B:80:1D auto-mac=no comment="created from master port" name=bridge1 protocol-mode=none
/interface ethernet

set [ find default-name=ether1 ] name=ether1-WAN1
set [ find default-name=ether2 ] name=ether2-LAN1
set [ find default-name=ether3 ] name=ether3-LAN1
set [ find default-name=ether4 ] name=ether4-LAN1
set [ find default-name=ether5 ] name=ether5-LAN1-master
/interface bridge port
add bridge=bridge1 interface=ether2-LAN1
add bridge=bridge1 interface=ether3-LAN1
add bridge=bridge1 interface=ether4-LAN1
add bridge=bridge1 interface=ether5-LAN1-master
/ip neighbor discovery-settings
set discover-interface-list=!dynamic

/ip address
add address=10.10.10.1/24 interface=ether1-WAN1 network=10.10.10.0
add address=192.168.0.1/24 interface=bridge1 network=192.168.0.0
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1-WAN1