Прочее:Ограничение скорости (шейпер)

Материал из MikroTik WiKi rus
(перенаправлено с «Прочее:Ограничение скорости»)
Перейти к: навигация, поиск

Per Connection Queue (PCQ) разновидность очередей, которая может быть использована для того, что бы динамически выравнять или ограничить трафик множеству пользователей.

Схема сети

схема сети (ограничение скорости (шейпер) на МикроТик)

Ограничение скорости для всех

Задача: всем пользователям ограничить скорость выгрузки на 5 Мб/с, а скорость загрузки на 10 Мб/с. В этом условии подразумевается, что ограничение общее на всех, а не на каждого пользователя в отдельности. Т. е. 1 пользователь сможет делать загрузку со скоростью 10 Мб/с, 2 пользователя - со скоростью 5 Мб/с, 4 пользователя - со скоростью 2,5 Мб/с и т. д.

Простой вариант

Для идентификации интерфейсов можно указать их имена:
/queue simple
add dst=ether1-LAN1 max-limit=5M/10M name="Internet download/upload limit" target=ether5-WAN1


или IP-адреса:
/queue simple
add dst=192.168.15.0/24 max-limit=5M/10M name="Internet download/upload limit" target=10.1.100.0/24


или любую их комбинацию:
/queue simple
add dst=ether1-LAN1 max-limit=5M/10M name="Internet download/upload limit" target=10.1.100.0/24


Так же можно указать только один внешний интерфейс:
/queue simple
add max-limit=5M/10M name="Internet download/upload limit" target=ether5-WAN1


или только внутренний, но тогда параметр target надо указать явно пустым:
/queue simple
add dst=ether1-LAN1 max-limit=128k/128k name="Internet download/upload limit" target=""

Вариант с двумя Интернет-каналами

Допустим у нас два Интернет-канала (второй Интернет-интерфейс ehter6-WAN2) и ограничение должно быть одинаковым. Тогда надо перечислить оба интерфейса в параметре target:
/queue simple
add dst=ether1-LAN1 max-limit=5M/10M name="Internet limit" target=ether5-WAN1,ether6-WAN2

Если же ограничение должно быть разным для каждого канала, то надо создать два отдельных правила.

Ограничение скорости для каждого

Задача: каждому отдельному пользователю ограничить скорость выгрузки на 1 Мб/с, а скорость загрузки на 2 Мб/с. Т. е. один пользователь будет загружать со скоростью 2 Мб/с, 2 пользователя будут загружать, каждый со скоростью 2 Мб/с, т. е. суммарно 4 Мб/с, 4 пользователя будут загружать, каждый со скоростью 2 Мб/с, т. е. суммарно 8 Мб/с и т. д. пока суммарная скоростью "не упрется" в скорость Интернет-канала.

Вариант №1

/queue type
add name="pcq-download" kind=pcq pcq-rate=2M pcq-classifier=dst-address
add name="pcq-upload" kind=pcq pcq-rate=1M pcq-classifier=src-address


/queue simple
add name="Internet download/upload limit" target=ether5-WAN1 queue=pcq-upload/pcq-download

Вариант №2

/ip firewall mangle
add chain=prerouting action=mark-packet in-interface=ether5-WAN1 new-packet-mark=client_upload
add chain=prerouting action=mark-packet in-interface=ether1-LAN new-packet-mark=client_download


/queue type
add name="pcq-download" kind=pcq pcq-rate=2M pcq-classifier=dst-address
add name="pcq-upload" kind=pcq pcq-rate=1M pcq-classifier=src-address


/queue tree
add name="Internet download limit" parent=global queue=pcq-download packet-mark=client_download
add name="Internet upload limit" parent=global queue=pcq-upload packet-mark=client_upload

Ограничение скорости для всех суммарно и для каждого в отдельности

Задача: каждому отдельному пользователю ограничить скорость выгрузки на 1 Мб/с, а скорость загрузки на 2 Мб/с. При этом суммарная скорость выгрузки всеми пользователями одновременно не должна превышать 5 Мб/с, а загрузки 10 Мб/с. Т. е. один пользователь будет загружать со скоростью 2 Мб/с, 2 пользователя будут загружать, каждый со скоростью 2 Мб/с, т. е. суммарно 4 Мб/с, 5 пользователя будут загружать, каждый со скоростью 2 Мб/с, т. е. суммарно 10 Мб/с, а 6 пользователей "упрутся в потолок 10 Мб/с на суммарную загрузку и будут загружать со скоростью 10 Мб/с / 6 = 1,66 Мб/с (max-limit / количество подключений).

/queue type
add name="pcq-download" kind=pcq pcq-rate=2M pcq-classifier=dst-address
add name="pcq-upload" kind=pcq pcq-rate=1M pcq-classifier=src-address


/queue simple
add name="Internet download/upload limit" max-limit=5M/10M target=ether5-WAN1 queue=pcq-upload/pcq-download

Режим вспышки (Burst) (временное превышение скорости, указанной в параметре max-limit)

Burst - это опция, которая позволяет на ограниченный промежуток времени увеличить скорость даже, если в параметре max-limit в настройках очереди (queue) указана более низкая скорость.

Вспышка может произойти только, если average-rate очереди за последние burst-time секунд меньше чем burst-threshold.
Вспышка остановится, если average-rate очереди за последние burst-time секунд больше или равно burst-threshold.

Механизм Вспышки очень простой. Если Вспышка разрешена, то значение параметра max-limit заменяется на значение параметра burst-limit. Когда наступает запрет на Вспышку, то значение max-limit возвращается на свое место.

  1. burst-limit (число) : максимальная скорость выгрузки/загрузки, которое может быть достигнуто пока Вспышка разрешена.
  2. burst-time (время) : период времени в секундах через который подсчитывается среднее значение скорости (Это НЕ время, которое будет работать вспышка).
  3. burst-threshold (число) : значение при котором Вспышка будет включаться/выключаться.
  4. average-rate (read-only) : каждую 1/16 времени указанного в параметре burst-time маршрутизатор подсчитывает среднее значение of each class over the last burst-time seconds.
  5. actual-rate (read-only) : актуальное значение скорости передачи в очереди.
Максимальная продолжительность вспышки = burst-threshold * burst-time / burst-limit

Пример

Значения: limit-at=1M, max-limit=2M , burst-threshold=1500k , burst-limit=4M

Клиент попытается загрузить 2 блока данных по 4 МБайта (32 Мбита). Первая загрузка начнется на нулевой секунде, а вторая начнется на 17-ой секунде. Последнюю минуту трафик через маршрутизатор не проходил.

Burst-time=16s

/queue simple
add burst-limit=4M/4M burst-threshold=1500k/1500k burst-time=16s/16s dst=\

      ether1-LAN1 limit-at=1M/1M max-limit=2M/2M name=\
      "Internet download/upload limit" target=ether5-WAN1

График ограничения скорости на МикроТик, 1 График ограничения скорости на МикроТик, 2

Как можно увидеть из графика первые 6 секунд клиент получил скорость 4Мб/c. Это самый длительный период вспышки с заданными значениями (самое длинное время вспышки = burst-threshold * burst-time / burst-limit). Как только время вспышки заканчивается в силу вступает значение max-limit, т. е. в нашем случае 2 Мб/с. С такой скоростью блок данных был загружен за 9 секунд. Без вспышки это заняло бы 16 секунд. У Вспышки есть 7 секунд для того, что бы обнулить счетчик до того, как начнется следующая загрузка.

Обратите внимание, что на момент начала второй загрузки Вспышка еще запрещена. Она запустится после, где-то к середине загрузки. С этим примером мы показали, что Вспышка может случиться и в середине загрузки. Продолжительность вспышки составила приближенно 4 секунды и второй блок был загружен приближенно на 4 секунды быстрее, чем это было бы без Вспышки.

Среднее значение подсчитывается каждые 1/16 значения burst-time. В нашем примере это 1 секунда.

Timeaverage-rateburstactual-rate
0(0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0)/16=0Kbpsaverage-rate < burst-threshold → Вспышка разрешена4Mbps
1(0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+4)/16=250Kbpsaverage-rate < burst-threshold → Вспышка разрешена4Mbps
2 (0+0+0+0+0+0+0+0+0+0+0+0+0+0+4+4)/16=500Kbps average-rate < burst-threshold → Вспышка разрешена4Mbps
3 (0+0+0+0+0+0+0+0+0+0+0+0+0+4+4+4)/16=750Kbps average-rate < burst-threshold → Вспышка разрешена4Mbps
4 (0+0+0+0+0+0+0+0+0+0+0+0+4+4+4+4)/16=1000Kbpsaverage-rate < burst-threshold → Вспышка разрешена4Mbps
5 (0+0+0+0+0+0+0+0+0+0+0+4+4+4+4+4)/16=1250Kbpsaverage-rate < burst-threshold → Вспышка разрешена4Mbps
6 (0+0+0+0+0+0+0+0+0+0+4+4+4+4+4+4)/16=1500Kbpsaverage-rate = burst-threshold → Вспышка не разрешена2Mbps
7 (0+0+0+0+0+0+0+0+0+4+4+4+4+4+4+2)/16=1625Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps
8 (0+0+0+0+0+0+0+0+4+4+4+4+4+4+2+2)/16=1750Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps
9 (0+0+0+0+0+0+0+4+4+4+4+4+4+2+2+2)/16=1875Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps
10(0+0+0+0+0+0+4+4+4+4+4+4+2+2+2+2)/16=2Mbpsaverage-rate > burst-threshold → Вспышка не разрешена0Mbps
11(0+0+0+0+0+4+4+4+4+4+4+2+2+2+2+0)/16=2Mbpsaverage-rate > burst-threshold → Вспышка не разрешена0Mbps
12(0+0+0+0+4+4+4+4+4+4+2+2+2+2+0+0)/16=2Mbpsaverage-rate > burst-threshold → Вспышка не разрешена0Mbps
13(0+0+0+4+4+4+4+4+4+2+2+2+2+0+0+0)/16=2Mbpsaverage-rate > burst-threshold → Вспышка не разрешена0Mbps
14(0+0+4+4+4+4+4+4+2+2+2+2+0+0+0+0)/16=2Mbpsaverage-rate > burst-threshold → Вспышка не разрешена0Mbps
15(0+4+4+4+4+4+4+2+2+2+2+0+0+0+0+0)/16=2Mbpsaverage-rate > burst-threshold → Вспышка не разрешена0Mbps
16(4+4+4+4+4+4+2+2+2+2+0+0+0+0+0+0)/16=2Mbpsaverage-rate > burst-threshold → Вспышка не разрешена0Mbps
17(4+4+4+4+4+2+2+2+2+0+0+0+0+0+0+0)/16=1750Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps
18(4+4+4+4+2+2+2+2+0+0+0+0+0+0+0+2)/16=1500Kbpsaverage-rate = burst-threshold → Вспышка не разрешена2Mbps
19(4+4+4+2+2+2+2+0+0+0+0+0+0+0+2+2)/16=1375Kbpsaverage-rate < burst-threshold → Вспышка разрешена4Mbps
20(4+4+2+2+2+2+0+0+0+0+0+0+0+2+2+4)/16=1375Kbpsaverage-rate < burst-threshold → Вспышка разрешена4Mbps
21(4+2+2+2+2+0+0+0+0+0+0+0+2+2+4+4)/16=1375Kbpsaverage-rate < burst-threshold → Вспышка разрешена4Mbps
22(2+2+2+2+0+0+0+0+0+0+0+2+2+4+4+4)/16=1375Kbpsaverage-rate < burst-threshold → Вспышка разрешена4Mbps
23(2+2+2+0+0+0+0+0+0+0+2+2+4+4+4+4)/16=1500Kbpsaverage-rate = burst-threshold → Вспышка не разрешена2Mbps
24(2+2+0+0+0+0+0+0+0+2+2+4+4+4+4+2)/16=1500Kbpsaverage-rate = burst-threshold → Вспышка не разрешена2Mbps
25(2+0+0+0+0+0+0+0+2+2+4+4+4+4+2+2)/16=1500Kbpsaverage-rate = burst-threshold → Вспышка не разрешена2Mbps
26(0+0+0+0+0+0+0+2+2+4+4+4+4+2+2+2)/16=1500Kbpsaverage-rate = burst-threshold → Вспышка не разрешена2Mbps
27(0+0+0+0+0+0+2+2+4+4+4+4+2+2+2+2)/16=1625Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps
28(0+0+0+0+0+2+2+4+4+4+4+2+2+2+2+2)/16=1750Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps
29(0+0+0+0+2+2+4+4+4+4+2+2+2+2+2+2)/16=1875Kbpsaverage-rate > burst-threshold → Вспышка не разрешена0Mbps
30(0+0+0+2+2+4+4+4+4+2+2+2+2+2+2+0)/16=1875Kbpsaverage-rate > burst-threshold → Вспышка не разрешена0Mbps
31(0+0+2+2+4+4+4+4+2+2+2+2+2+2+0+0)/16=1875Kbpsaverage-rate > burst-threshold → Вспышка не разрешена0Mbps
Burst-time=8s

/queue simple
add burst-limit=4M/4M burst-threshold=1500k/1500k burst-time=8s/8s dst=\

      ether1-LAN1 limit-at=1M/1M max-limit=2M/2M name=\
      "Internet download/upload limit" target=ether5-WAN1

График ограничения скорости на МикроТик, 3 График ограничения скорости на МикроТик, 4

Если мы уменьшим burst-time до 8 секунд, то мы увидим, что в этом случае Вспышка доступна только в самом начале загрузки.

Среднее значение подсчитывается каждые 1/16 значения burst-time. В нашем примере это 0,5 секунды.

Timeaverage-rateburstactual-rate
0.0(0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+0)/8=0Kbpsaverage-rate < burst-threshold → Вспышка разрешена4Mbps (2Mb per 0,5sek)
0.5(0+0+0+0+0+0+0+0+0+0+0+0+0+0+0+2)/8=250Kbpsaverage-rate < burst-threshold → Вспышка разрешена4Mbps (2Mb per 0,5sek)
1.0(0+0+0+0+0+0+0+0+0+0+0+0+0+0+2+2)/8=500Kbpsaverage-rate < burst-threshold → Вспышка разрешена4Mbps (2Mb per 0,5sek)
1.5(0+0+0+0+0+0+0+0+0+0+0+0+0+2+2+2)/8=750Kbpsaverage-rate < burst-threshold → Вспышка разрешена4Mbps (2Mb per 0,5sek)
2.0(0+0+0+0+0+0+0+0+0+0+0+0+2+2+2+2)/8=1000Kbpsaverage-rate < burst-threshold → Вспышка разрешена4Mbps (2Mb per 0,5sek)
2.5(0+0+0+0+0+0+0+0+0+0+0+2+2+2+2+2)/8=1250Kbpsaverage-rate < burst-threshold → Вспышка разрешена4Mbps (2Mb per 0,5sek)
3.0(0+0+0+0+0+0+0+0+0+0+2+2+2+2+2+2)/8=1500Kbpsaverage-rate = burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
3.5(0+0+0+0+0+0+0+0+0+2+2+2+2+2+2+1)/8=1625Kbpsaverage-rate > burst-threshold → Вспышка не разрешена 2Mbps (1Mb per 0,5sek)
4.0(0+0+0+0+0+0+0+0+2+2+2+2+2+2+1+1)/8=1750Kbpsaverage-rate > burst-threshold → Вспышка не разрешена 2Mbps (1Mb per 0,5sek)
4.5(0+0+0+0+0+0+0+2+2+2+2+2+2+1+1+1)/8=1875Kbpsaverage-rate > burst-threshold → Вспышка не разрешена 2Mbps (1Mb per 0,5sek)
5.0(0+0+0+0+0+0+2+2+2+2+2+2+1+1+1+1)/8=2000Kbpsaverage-rate > burst-threshold → Вспышка не разрешена 2Mbps (1Mb per 0,5sek)
5.5(0+0+0+0+0+2+2+2+2+2+2+1+1+1+1+1)/8=2125Kbpsaverage-rate > burst-threshold → Вспышка не разрешена 2Mbps (1Mb per 0,5sek)
6.0(0+0+0+0+2+2+2+2+2+2+1+1+1+1+1+1)/8=2250Kbpsaverage-rate > burst-threshold → Вспышка не разрешена 2Mbps (1Mb per 0,5sek)
6.5(0+0+0+2+2+2+2+2+2+1+1+1+1+1+1+1)/8=2375Kbpsaverage-rate > burst-threshold → Вспышка не разрешена 2Mbps (1Mb per 0,5sek)
7.0(0+0+2+2+2+2+2+2+1+1+1+1+1+1+1+1)/8=2500Kbpsaverage-rate > burst-threshold → Вспышка не разрешена 2Mbps (1Mb per 0,5sek)
7.5(0+2+2+2+2+2+2+1+1+1+1+1+1+1+1+1)/8=2625Kbpsaverage-rate > burst-threshold → Вспышка не разрешена 2Mbps (1Mb per 0,5sek)
8.0(2+2+2+2+2+2+1+1+1+1+1+1+1+1+1+1)/8=2750Kbpsaverage-rate > burst-threshold → Вспышка не разрешена 2Mbps (1Mb per 0,5sek)
8.5(2+2+2+2+2+1+1+1+1+1+1+1+1+1+1+1)/8=2625Kbpsaverage-rate > burst-threshold → Вспышка не разрешена 2Mbps (1Mb per 0,5sek)
9.0(2+2+2+2+1+1+1+1+1+1+1+1+1+1+1+1)/8=2500Kbpsaverage-rate > burst-threshold → Вспышка не разрешена 2Mbps (1Mb per 0,5sek)
9.5(2+2+2+1+1+1+1+1+1+1+1+1+1+1+1+1)/8=2375Kbpsaverage-rate > burst-threshold → Вспышка не разрешена 2Mbps (1Mb per 0,5sek)
10.0(2+2+1+1+1+1+1+1+1+1+1+1+1+1+1+1)/8=2250Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
10.5(2+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1)/8=2125Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
11.0(1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1)/8=2000Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
11.5(1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1)/8=2000Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
12.0(1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1)/8=2000Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
12.5(1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1)/8=2000Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
13.0(1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1)/8=2000Kbpsaverage-rate > burst-threshold → Вспышка не разрешена0Mbps (0Mb per 0,5sek)
13.5(1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+0)/8=1875Kbpsaverage-rate > burst-threshold → Вспышка не разрешена0Mbps (0Mb per 0,5sek)
14.0(1+1+1+1+1+1+1+1+1+1+1+1+1+1+0+0)/8=1750Kbpsaverage-rate > burst-threshold → Вспышка не разрешена0Mbps (0Mb per 0,5sek)
14.5(1+1+1+1+1+1+1+1+1+1+1+1+1+0+0+0)/8=1625Kbpsaverage-rate > burst-threshold → Вспышка не разрешена0Mbps (0Mb per 0,5sek)
15.0(1+1+1+1+1+1+1+1+1+1+1+1+0+0+0+0)/8=1500Kbpsaverage-rate > burst-threshold → Вспышка не разрешена0Mbps (0Mb per 0,5sek)
15.5(1+1+1+1+1+1+1+1+1+1+1+0+0+0+0+0)/8=1375Kbpsaverage-rate < burst-threshold → Вспышка разрешена0Mbps (0Mb per 0,5sek)
16.0(1+1+1+1+1+1+1+1+1+1+0+0+0+0+0+0)/8=1250Kbpsaverage-rate < burst-threshold → Вспышка разрешена0Mbps (0Mb per 0,5sek)
16.5(1+1+1+1+1+1+1+1+1+0+0+0+0+0+0+0)/8=1125Kbpsaverage-rate < burst-threshold → Вспышка разрешена0Mbps (0Mb per 0,5sek)
17.0(1+1+1+1+1+1+1+1+0+0+0+0+0+0+0+0)/8=1000Kbpsaverage-rate < burst-threshold → Вспышка разрешена2Mbps (1Mb per 0,5sek)
17.5(1+1+1+1+1+1+1+0+0+0+0+0+0+0+0+1)/8=1000Kbpsaverage-rate < burst-threshold → Вспышка разрешена4Mbps (2Mb per 0,5sek)
18.0(1+1+1+1+1+1+0+0+0+0+0+0+0+0+1+2)/8=1125Kbpsaverage-rate < burst-threshold → Вспышка разрешена4Mbps (2Mb per 0,5sek)
18.5(1+1+1+1+1+0+0+0+0+0+0+0+0+1+2+2)/8=1250Kbpsaverage-rate < burst-threshold → Вспышка разрешена4Mbps (2Mb per 0,5sek)
19.0(1+1+1+1+0+0+0+0+0+0+0+0+1+2+2+2)/8=1375Kbpsaverage-rate < burst-threshold → Вспышка разрешена4Mbps (2Mb per 0,5sek)
19.5(1+1+1+0+0+0+0+0+0+0+0+1+2+2+2+2)/8=1500Kbpsaverage-rate = burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
20.0(1+1+0+0+0+0+0+0+0+0+1+2+2+2+2+1)/8=1500Kbpsaverage-rate = burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
20.5(1+0+0+0+0+0+0+0+0+1+2+2+2+2+1+1)/8=1500Kbpsaverage-rate = burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
21.0(0+0+0+0+0+0+0+0+1+2+2+2+2+1+1+1)/8=1500Kbpsaverage-rate = burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
21.5(0+0+0+0+0+0+0+1+2+2+2+2+1+1+1+1)/8=1625Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
22.0(0+0+0+0+0+0+1+2+2+2+2+1+1+1+1+1)/8=1750Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
22.5(0+0+0+0+0+1+2+2+2+2+1+1+1+1+1+1)/8=1875Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
23.0(0+0+0+0+1+2+2+2+2+1+1+1+1+1+1+1)/8=2000Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
23.5(0+0+0+1+2+2+2+2+1+1+1+1+1+1+1+1)/8=2125Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
24.0(0+0+1+2+2+2+2+1+1+1+1+1+1+1+1+1)/8=2250Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
24.5(0+1+2+2+2+2+1+1+1+1+1+1+1+1+1+1)/8=2375Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
25.0(1+2+2+2+2+1+1+1+1+1+1+1+1+1+1+1)/8=2500Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
25.5(2+2+2+2+1+1+1+1+1+1+1+1+1+1+1+1)/8=2500Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
26.0(2+2+2+1+1+1+1+1+1+1+1+1+1+1+1+1)/8=2375Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
26.5(2+2+1+1+1+1+1+1+1+1+1+1+1+1+1+1)/8=2250Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
27.0(2+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1)/8=2125Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
27.5(1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1)/8=2000Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
28.0(1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1)/8=2000Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
28.5(1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1)/8=2000Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
29.0(1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1)/8=2000Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
29.5(1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1)/8=2000Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
30.0(1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1)/8=2000Kbpsaverage-rate > burst-threshold → Вспышка не разрешена2Mbps (1Mb per 0,5sek)
30.5(1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+1)/8=2000Kbpsaverage-rate > burst-threshold → Вспышка не разрешена0Mbps (0Mb per 0,5sek)
31.0(1+1+1+1+1+1+1+1+1+1+1+1+1+1+1+0)/8=1875Kbpsaverage-rate > burst-threshold → Вспышка не разрешена0Mbps (0Mb per 0,5sek)